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ADVERTISEMENT

Dr. Geoff Bunza shows how to put this new highly 
affordable tiny computer to good use on your layout …

Model Railroad Hobbyist | March 2019 | #109

for model railroaders

Electrical 
Impulses

Model railroaders use computers more and more 
in their hobby to research topics, view magazines, program their 
DCC decoders, schedule operations, and control their layouts. 
Often modelers may use an older, hand-me-down PC or laptop 
for such activities. 

A new, low-cost, tiny computer that’s starting to gain ground as an 
attractive option is the “Raspberry Pi” or “RPi” for short.

Just a bit larger than a credit card, the RPi consumes little power, 
and often exceeds the capabilities of personal computers from 
several years back. The RPi also offers some additional capabilities 
which open new possibilities for modelers.
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1. Arduino Uno (left) and Raspberry Pi 3B (right).

There are several things a Raspberry Pi offers modelers that make 
it a winner:

�� It can run the full JMRI configuration including its DCC com-
mand station interfaces

�� It can power up managing its own, independent, WiFi net-
work supporting wireless throttles 

�� It is low-cost ($39), small-sized (3.35”x2.2”), and uses little 
power 

�� It can run with or without a monitor, keyboard, and mouse
�� You don’t need to program it!

Unlike the small Arduino controllers I have discussed before (MRH 
December 2016 and MRH March 2017), the RPi offers much more 
capability. Like your laptop, it runs an operating system (OS). Its 

Rate this article
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Learning more about JMRI
The Java Model Railroad Interface (JMRI) is 
free, widely used, and growing in support. 
JMRI has free software applications that 
run on Windows, Linux, or a Mac that can 
perform a multitude of useful model rail-
roading functions.
JMRI makes programming complex DCC 
decoders much easier. It can also be used 
for dispatching, signaling, switching, route 
control, train control, and more.
If you need more info about JMRI, just visit 
the web link below.

WEB: jmri.sourceforge.net/help/en/webtoc.shtml

G. Bunza

OS, called “Linux,” supports displays, keyboards, mice, USB inter-
faces, SD memory cards, and best of all: the Java Model Railroad 
Interface (JMRI).

I will assume the reader has a basic acquaintance with JMRI. If not, 
see my side note on where to learn more about JMRI.

This article is not focused on the technical intricacies of the RPi 
or JMRI. Instead it provides a step-by-step process for a modeler 
to set up an RPi and get it going nearly instantly. I provide some 
different variations, including one with its own WiFi network for 
wireless throttles.

Later, I’ll suggest some additional customization modelers might 
like to consider.
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From off-the-shelf to do-it-yourself solutions
A year or two ago, I saw a demonstration at our local NMRA 
divisional meet of a new product called the Pi-SPROG given by 
Bill Chown of the BBM Group (sprog@bbmgroup.com). I was 
impressed with its compact size and performance.

When I later needed a compact solution for a JMRI operating 
demo, Bill was incredibly helpful answering questions, and I 
quickly got up and running. The Pi-SPROG is a complete, com-
mercial package consisting of an RPi Model B, a special SPROG 

2. Pi-SPROG components.
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plug-in board, a pre-configured and pre-loaded micro SD mem-
ory card (like the ones used in some cameras), a power supply, 
and a small enclosure for the boards.

The micro SD card acts as the hard disk drive found in your laptop 
or personal computer. I think it took me longer to read the docu-
mentation than it did for me to connect everything and get a train 
running for my demo!

Later, I will step through creating your own RPi setup from scratch.

The Pi-SPROG memory card comes pre-loaded with the correct 
version of Linux and JMRI, and default configuration setup for the 
Pi-SPROG DCC board to form a complete DCC command station.

The SPROG board that easily plugs into the RPi is the equivalent of a 
separate SPROG DCC interface with which you may already be famil-
iar. The RPi runs JMRI, just as it would run on your PC or laptop.

The very best part is that the Model 3 B (and 3 B+) of RPi can 
also act as a self-contained WiFi network. The RPi has the WiFi 
hardware, and JMRI provides the wireless throttle protocol. 
So after a quick setup of my cell phone and its WiThrottle (or 
Engine Driver) app, I was running a loco via wireless control.

4. Raspberry Pi 3B (left) and Raspberry Pi 3B+ (right).
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If you want an off-the-shelf solution for using an RPi, the 
Pi-SPROG is a solid solution.

WiFi throttles need locos defined in JMRI with their respective 
decoders before use. Once I added a USB keyboard, a USB mouse, 

5. R5V Power Adapter 
with micro USB plug.

6. Micro SD memory card [top] plugged 
into an adapter that goes into a USB 
socket on the computer. Below is a 16 GB 
MicroSD memory card adapter that plugs 
into a larger SD card socket.

7. USB Keyboard and USB Mouse.

Raspberry Pi for modelers | 7
and a small computer display with an HDMI interface to the RPi, 
I could use JMRI directly to add the appropriate roster informa-
tion in JMRI.

These devices can be left disconnected once everything is setup. I 
also have an alternative to adding these, which I will cover later.

8. Displays with HDMI Interface (24-Inch & two 7-inch). 

9. VGA to HDMI Adapter & HDMI Cable.
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More slices of Raspberry Pi – Variations on a 
great application

As an electronics-centric modeler, once I realized the capabili-
ties of the RPi-SPROG, I now wanted build an RPi setup from the 
ground up.

The component parts can be obtained from a multitude of 
sources worldwide including: adafruit.com, amazon.com, frys.
com, and sparkfun.com. 

Unlike many of my other projects, I am not recommending the 
cheapest or smallest components. Instead, go for quality parts. 

Since the RPi is so powerful, these may well become the back-
bone of your DCC system. 

The essential components include:

1.	 A Raspberry pi 3B or Raspberry Pi 3B+ module (stick to these, 
they are the newer and more capable models)

2.	 Wall adapter power supply 5.0 volts DC, 2 amps (with USB 
Micro-B connector)

3.	 An 8 GB (8 GB-32GB will work) micro SD memory card (I rec-
ommend the faster “HC” versions)

4.	 And (temporarily, which means you do not have to dedicate 
these to your RPi system after setup is completed):

■	 USB keyboard

■	 USB mouse

■	 Display (HDMI or VGA display with VGA-to-HDMI adapter)

Raspberry Pi for modelers | 9

STEP 1: All the software you will need

10. The Etcher program loads your micro SD card.

Next I wanted to see if I could build a new RPi SD card image 
with multiple configurations and applications. There is some 
early documentation showing difficulties creating the SD im-
age for the RPi.

Indeed, I did have some difficulties at first, but I have put 
everything you need to easily build a working SD card image 
in the additional materials accompanying this article [bonus 
download link].

You can download the entire disk image and put it on your 
own SD card, which is the main “disk” for the RPi. I recom-
mend a 16 GB Micro HC Memory card, but an 8 GB card and/
or slower speed card will do if necessary.
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Insert the micro SD memory card into your SD-USB adapter 
[6]. Download and extract Etcher-Portable-1.4.4-x86.exe 
and rpisdcard.img files from this article’s bonus materials.

When you run Etcher, the window in [10] should appear. 
Select the rpisdcard.img file and your micro SD card, and 
hit Flash. This will take a while.

Once complete, your SD card will have the most current soft-
ware, updated at the time of this writing, including JMRI, Java, 
and the current Arduino software too. This disk image is a de-
rivative version I compiled based on the fine work of Steve Todd.

NOTE: If you’re interested, Steve Todd offers his own RPi im-
age and excellent information about customizing it for your 
needs: mstevetodd.com/jmri-raspberrypi-access-point 
– I highly recommend it for further reading.

Once the load is 
done, place the 
micro SD card 
into the socket 
on the back of 
your Raspberry Pi 
Board [11].

Raspberry Pi for modelers | 10

11. Micro SD memory card inserted 
into RPi socket.

continued ... STEP 1: All the software ...
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STEP 2: Assemble the components

Plug your USB mouse and keyboard [7] into any two of the 
USB sockets on the end of the RPi card [12]. Leave the wired 
network connection alone for now.

Now, set up your display. Connect the display’s HDMI cable to 
the connector on the side of the Raspberry Pi card [13]. Turn 
on the display.

12. USB sockets and Wired Network (LAN) connectors.

13. Raspberry Pi power and HDMI connectors.
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STEP 3: Power on
Lastly, connect your 5V power adapter’s micro USB plug to the 
power connector on the side of the RPi [13]. Plug the power 
adapter into an AC socket. If it has a power switch in the 
cable, turn it on.

After a short time, your RPi should power up, and automatically 
run JMRI. Thanks to Steve Todd’s work, if you plug in a 
computer interface to your DCC command station and it is 
one of the preconfigured interfaces Steve has set up, JMRI 
will recognize it, and automatically pre-configure itself for 
operations. The list of preconfigured interfaces is in Step 4. 

For now, let it power up and display the startup screen [14].

14. RPi Power-on screen.

Raspberry Pi for modelers | 13

You can follow the power-on sequence in [Video], and famil-
iarize yourself with the screen layout. This will give you a good 
orientation in the remaining steps. 

Since we have not connected the DCC command station inter-
face, JMRI is set to power up to the Digitrax Loconet Simula-
tor configuration, which we can use for testing later.

continued ... STEP 3: Power on ...

Video: The Raspberry Pi start up sequence video.

View reader 
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STEP 4: Connect DCC command station
Once you get to the screen in [14], you are almost done. Again, 
thanks to Steve Todd’s work, the boot-up includes an auto-
configure mechanism that’s included in the disk image. It 
accounts for the following configurations:

DCC++ to an Arduino using the FTDI USB interface

DCC++ to an Arduino using the CH340G USB interface 
(newly added to this disk)

Digitrax Simulator

EasyDCC Serial

LENZ Simulator

LENZ USB

Locobuffer-USB to Digitrax

MERG USB

NCE Serial

NCE USB

PR3 to Digitrax

Pi-SPROG Nano

Pi-SPROG One

RPi

Sprog Rate this article
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If your desired JMRI DCC command station configuration is not 
listed, don’t worry. Simply open JMRI and set up the configuration 
for your command station, then re-start JMRI. You might contact 
Steve to ask if he can add it to the auto-configuration list.

Connect your DCC command station USB interface to one of 
the available ports and re-start the RPi. Once JMRI fully comes 
up, you should be able to select from the top Panel Pro menu 
Tools-> Power Control.

From the small window that opens, you should be able to turn 
your layout DCC power on and off.

continued ... STEP 4: Connect DCC ...
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STEP 5: Arduino and DCC++ (optional) 
For those modelers using DCC++/Arduino USB connections, note 
that RPi does not use COM port designations. instead, serial ports 
usually are designated by “tty. . .” (e.g., tty01, tty05) (teletype). In 
my installation, the Arduino Uno USB port shows up as “ttyUSB0.”

In the disk image you loaded, and on the RPi window that opens 
up when you start the RPi, you will find the Arduino IDE already 
loaded for your RPi.

If your Arduino or DCC++ command station is plugged into your 
RPi, you can open the IDE by double-clicking the icon. Go to 
the Tools menu, then pick the Port. On a Raspberry Pi 3B+ you 
should see a port list like: /dev/ttyAMA0, /dev/ttyS0, and /dev/
ttyUSB0.

If you unplug your Arduino USB cable, you will see the /dev/tty-
USB0 disappear. But note well: if you plug it back in, the RPi will 
likely assign a new designation like: /dev/ttyUSB1, which may 
well mess up previous settings, so be careful. Plug and unplug 
your USB cables before powering up.

There has been some confusion using the RPi with DCC++ 
configurations, in part because vendors of Arduino Uno’s and 
Mega2560’s have substituted a cheaper USB interface chip, the 
CH340. I have added a DCC++ configuration using this inter-
face to facilitate using this variation. The appropriate driver is 
included and is recognized by the Raspian version 9 operating 
system on your disk.

Raspberry Pi for modelers | 17

I’ve written several times before about installing and loading 
Arduino software in MRH December 2016, “A modeler’s introduc-
tion to the Arduino” [mrhpub.com/2016-12-dec/online] and 
in MRH March 2017, “DCC projects using the Arduino” ... 
[mrhpub.com/2017-03-mar/online/html5].

While we are discussing the Arduino setup, if you start the Ar-
duino IDE and select File->Open… from the menu and select 
Arduino at the top-left of the open window, you will see all the 
Arduino sketches from my MRH Arduino articles. 

This is everything from my December 2015 and March 2016 MRH 
articles, including the DCC++ and DCC decoders sketches. Yes, 
you can program your Arduino from your RPi!

continued ... STEP 5: Arduino & DCC++ ...

15. Basic DCC++ setup – The USB cable connects 
directly to the RPi.
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STEP 6: Turn cell phone into DCC throttle 
I mentioned before that one of the great benefits of using the RPi 
with JMRI is the WiFi capability built into the RPi module. When 
Panel Pro opens on your RPi, you should also see a window at 
the top of your screen labeled “WiThrottle.” It should also show 
“192.168.6.1:12090”

This is the IP address (192.168.6.1) and port number (12090) 
for your RPi, running its own wireless network, identified (SSID) 
as “model-rr” with an access password of “model-rr” that I will 
show you how to change later. You will need this information.

The easiest way to access and use the WiThrottle interface to 
run your layout is to load a free application (App) onto your cell 
phone or tablet that is WiFi-capable. On an iPhone the App is 
called “WiThrottle” – pretty clever, eh?

On an Android WiFi device it is called “Engine Driver.” These 
are free on  the Apple App Store and the Google Play Store respec-
tively. First go to settings and set your phone or tablet to access 
the WiFi for SSID: model-rr, and the password: model-rr.

You will need to provide the IP address 192.168.6.1 and port: 
12090 when you first set the server for your WiThrottle or En-
gine Driver App.

Raspberry Pi for modelers | 19

continued ... STEP 6: Cell phone throttle ...

16-19. WiThrottle setup: server setup, enter loco 
address, set loco address, change to throttle and run!

20-22. Engine Driver Setup: server setup, set loco 
address, change to throttle and run!

View reader 
comments
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Once you connect to the RPi’s 
WiFi network, you can try control-
ling a loco. But first, let’s test the 
connection:

Step A: On the Panel Pro Window 
on the RPi, select Tools-> Throt-
tles->New Throttle and in the 
Address Panel in the Throttle 
Window type an arbitrary address, 
like 6. 

Hit Set, and see if you can toggle 
the Off (red) / On (green) power 
button at the top right of the 
Throttle window. If not, some-
thing is not set up correctly.

Step B: Assuming you got this far, 
go to your WiFi handheld throttle 
(your cell phone or tablet), and 
enter the same loco address (6) 
and hit Set.

Step C: Now go change the speed 
setting for this imaginary loco (6) 
on your handheld throttle and 
watch the throttle speed indicator 
move on your RPi! You are now 
capable of running your trains on 
your own private network.

continued ... STEP 6

ADVERTISEMENT

ADVERTISEMENT
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STEP 6: Customizing your RPi (optional)

There may be some things you would like to change on your 
RPi. You will find a wealth of information on the web, includ-
ing Steve Todd’s website: : mstevetodd.com/jmri-raspberrypi-
access-point.

Let me add some quick notes which may be of help if you would 
like to make some changes. Most of these need to be typed in a 
“terminal window” which you can open by clicking on the black 
terminal window icon in the upper left menu bar [23].

23. RPi Main menu bar icons (top-left).  
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Here are some additional useful notes for modelers:

1.	 If you already have a JMRI loco roster entered on another 
computer, you can open the JMRI on your other computer 
and from the top menu bar click Roster->Export Com-
plete Roster…, enter a file name, and save it to a USB 
drive which you can insert into your RPi and then from 
the JMRI top menu bar click Roster->Import Exported 
Roster…, enter a file name, and save the entries you want 
in the RPi JMRI installation.

continued ... STEP 6: Customizing ...

ADVERTISEMENT
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continued ... STEP 6: Customizing ...
2.	 In the terminal window, type lsblk to see which devices 

are currently connected to your machine. You will likely 
find mmcblk0 as the main RPi disk, and if you inserted a 
separate USB drive, it may be listed as sda or sda1.

3.	 When you insert a USB drive into a running RPi, it will 
ask you if you want to look at the new drive with the 
File Manager (also accessible on the main RPi menu 
bar, the top-left). This tool is very similar to the MS 
Windows file explorer and will let you move, copy, and 
delete files and folders.

4.	 To change your WiFi SSID and password, click File Man-
ager from the top menu bar, and instead of /home/pi 
in the entry bar, type /etc/hostapd and hit enter. Right 
click hostapd.conf, and select Open With… -> +Ac-
cessories -> Text Editor, then OK. Then edit the lines 
SSID=model-rr and wpa_passphrase=model-rr 
to whatever you want to name your network and its 
associated password, like: SSID=my_WiFi and wpa_
passphrase=supersecret. Then save and quit the edi-
tor. Re-booting your RPi should follow.

5.	 To safely unload and eject a USB drive that you plugged 
into your RPi ( for file transfers), click the up arrow on 
the far upper-right of the main menu bar. A list of devices 
should appear. Select the one you want to eject, and a 
message should appear saying that it is now safe to re-
move the device.
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continued ... STEP 6: Customizing ...
6.	 To change the screen resolution on your display, click the 

raspberry icon (the Applications menu icon labeled in 
[23]), then Preferences -> Raspberry Pi Configura-
tion and the Raspberry Pi Configuration window should 
open. Next click Set Resolution… -> then down arrow, 
and select the new screen resolution you want.

7.	 To shut down your RPi in an orderly fashion, click the 
raspberry icon (the Applications menu icon labeled in 
[23]), then Shutdown… and in the new small window 
that opens click Shutdown again. Wait for the small in-
dicator light on your RPi to stop blinking, then turn off the 
power. Caution here – see our note below.

8.	 There is another alternative to equipping your RPi with 
its own mouse, keyboard, and display – VNC Viewer. If 
you have a WiFi-equipped laptop or PC, you can load, run, 
and configure VNC Viewer to open a window on your PC 
that will behave as if it were the display on the RPi. The 
mouse and keyboard on your laptop will act as if they were 
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continued ... STEP 6: Customizing ...
directly connected to the RPi as well. Sometimes called 
a “virtual or remote desktop,” it will give you full access 
to set up and configure your RPi and its applications, like 
JMRI. You can find the documentation and the software 
here: www.realvnc.com/en/products/viewerplus/ 
 

Download a copy for free, personal use. VNC will need to 
be configured on both your laptop or PC and on your RPi. 
It is already installed on your RPi, with a general access 
password of “model-rr” which can be changed to suit your 
needs.

9.	 You can plug your RPi into your home network (your 
LAN) via an Ethernet cable to the “Wired Network” jack in 
[12]. If your home router is set to automatically assign IP 
addresses (via DHCP), the RPi will auto-connect and give 
your RPi the same capabilities as if you connected your 
laptop to your net, including web access if it has it. Click 
the blue globe icon on the upper left main menu bar on 
the RPi screen to open a web browser.

10.	When using VNC, remember to shut down the RPI as in-
structed per #7 in this list.

There are many more things that a modeler can do with an 
RPi. This article should get you started on a whole series of 
new adventures in model railroading, quickly, and for rela-
tively low cost! Have fun! ☑

RPi powering down best practices
The web is full of warnings to never power 
down an RPi by just killing the power. Always 
do the orderly shutdown recommended by 

Geoff in #7, above. If you have a “headless” RPi, you 
can add an orderly shutdown power button using one 
of these aftermarket kits: mausberrycircuits.com. Or if 
you’re more adventurous, here is a do-it-yourself video:  
youtu.be/W5YTm0xkCb8 Rate this article

M. Dodd
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Dr. Geoff Bunza
Geoff Bunza started as a model railroader when he 
received a Mantua train set for Christmas, at age 6.  He 
fed his interests through college, becoming a member of 
the Tech Model Railroad Club (TMRC) at MIT while get-
ting his doctorate and three other degrees in electrical 
engineering. He has collected Lionel HO trains for many 

years, which spawned his interest in realistic model animation and control. 
Primarily, he models the New York Central Railroad. 

Geoff is a member of the New York Central System Historical Society, a life 
member of the NMRA, and holds an Extra Class amateur radio license. ■
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